This project is read-only.

Files in your project exceed MAX_PATH

Jan 2, 2015 at 8:55 PM
I have an existing nodejs project.
I created that using Yeoman generator (
running "grunt serve" compiles,tests and runs project.

Now when i create a new project using existing nodejs and do a build, i get below error
"Error 18 Files in your project exceed MAX_PATH, please move your project to a location with a shorter path.
C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Node.js Tools\Microsoft.NodejsTools.targets"
Can you help me how to fix this
Jan 2, 2015 at 9:56 PM
Hi supersniper, Windows places a a 260 character length limit on file names. This unfortunately conflicts with the node_modules nested directory structure. We recommend first moving your project to a location with as short a path as possible (e.g. c:\src). If that doesn't work, you can also try running 'npm dedupe' in your root project folder to simplify your local package tree.
Jan 5, 2015 at 5:47 PM
Edited Jan 5, 2015 at 5:48 PM
Sorry for the late reply (somehow i didnt get the email notification). I tried both, and it still doesnt work.
I think you can reproduce it as well, follow bellow steps

npm install -g generator-angular-fullstack
yo angular-fullstack foodies
select options,
  • Scripts: JavaScript
  • Markup: HTML,
  • Stylesheets: Stylus,
  • Angular Routers: ui-router
  • Database: MongoDB and mongoose
  • Authentication boilerplate: Yes
  • oAuth integrations: Facebook Twitter Google
  • integration: Yes
Now try to import this in visual studio and you will get the MAX_PATH error
Apr 28, 2015 at 9:31 AM
Same problem with different npm packages. Does this mean that there is no guarantee that a node project can be built on windows? o_O
Apr 28, 2015 at 9:37 AM
Please see thread here for workarounds:

Codeplex discussions have been deprecated with our recent move to github.