This project is read-only.

Unable to enter debug mode

Apr 6, 2014 at 6:24 PM
Edited Apr 11, 2014 at 3:35 PM
I use F5 to start my program, but it does not automatically open the browser to run, has been staying in the picture frame, I try to use CTRL + F5 to run properly, I do not understand where the problem lies, and whether to give assistance?

My environment:
Visual Studio 2012
Chrome 33.0.1750

Apr 7, 2014 at 10:11 PM
hi, your screenshot didnt come across as you can see.

can you post it somewhere (like and link to it?
Apr 11, 2014 at 3:38 PM
I've updated the image storage site, I suspect that the problem resulted in window8.
Apr 11, 2014 at 7:40 PM
i have the same problem under windows 8 with both vs 2012 and vs 2013.

but i tested on server 2008 (same os core as 7)? it's still the same...

anyone can solve this?
Apr 12, 2014 at 9:25 AM
Edited Apr 12, 2014 at 9:27 AM
edit: fixed picture link and code
I've got the same issue,
I'm not much of a VS/Web developer - just starting with nodejs :)

I found a workaround (but doing this breaks debugging functionality)

Right click the project and choose properties
Under node.exe arguments put the full path of the server.js/app.js (you can right click it and choose copy full path)
When starting the project now, a new browser won't be opened, but the server will at least run and can be accessed using the browser.

Not sure if the following is helpful but may give someone an idea:
Created a new node app with the following code:
var http = require('http');
var port = process.env.port || 1337;
http.createServer(function (req, res) {
    res.writeHead(200, { 'Content-Type': 'text/plain' });
    res.end('Hello World\n');
I don't see "0","1","2","3","4" logged on the console.

When I look at what's being run using procmon, it's the following command line:
"C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Microsoft\Node.js Tools\1.0\Microsoft.NodejsTools.PressAnyKey.exe" abnormal C:\Users\myusername_000\AppData\Local\Temp\tmpE7A4.tmp "C:\Program Files\nodejs\node.exe" --debug-brk=5858 "c:\temp\NodejsApp1\NodejsApp1\server.js"

From the documentation at:
it's noted that:
My script runs too fast to attach the debugger.

The debugged process must be started with --debug-brk, this way the script is paused on the first line.

netstat -ano shows:
netstat -ano | Select-String "5858"


process 11920 is devenv
process 2140 is node

I used rawcap to take a look at the traffic on with the debugger, at least on the surface it seems that VS is talking to the debugger.
I'm guessing this is expected and that node tools for VS should interact with the debugger to resume execution but that's not happening for some reason.

I'll be happy to send the procmon log/rawcap capture.
Apr 13, 2014 at 10:19 AM
i have exactly the same problem under windows 7 (x64) with vs 2013 with node (x64). The previous dev version doesn't work either, but the alpha version does work.

i also tried to attach to a nodejs process i manually opened with --debug-brk. It fails with a message box prompting for invalid pointer(or handle or something like that, i don't remember).

I'll downgrade to the alpha version before this get fixed.
Apr 14, 2014 at 12:46 AM
I am also seeing this issue and would love a suggestion. I am using VS2013 Update 2 RC on the most current version of Windows 8.1. I have had similar experiences as other users in that the Alpha version seemed to work. That said, I did get the plug-in to work on my Laptop that has a nearly identical configuration. I also tried un-installing then re-installing the extension, no help. I also tried to remove/disable a number of other extensions that I, like Telerik JustCode, and the WebExtensions. No help.
Apr 14, 2014 at 11:11 AM
Edited Apr 14, 2014 at 11:13 AM
  1. Change the app.js(execute js file) encoding to "Unicode (UTF-8 without signature) - Codepage 65001"
  2. Try Debug.
Apr 14, 2014 at 6:51 PM
I have the exact same issue and changing the encoding did not resolve it.

VS2013 / Win 8.1
Apr 20, 2014 at 11:56 AM
gtk2k wrote:
  1. Change the app.js(execute js file) encoding to "Unicode (UTF-8 without signature) - Codepage 65001"
  2. Try Debug.
I used the Sublime Text 2 /File/Save File Encoding/UTF-8 , and not work either.

I notice that the node version on the introduction video(00:07:31) is 32 bit , may be that,let me try first ...
Apr 20, 2014 at 12:19 PM
I fail ...

I tried to change the node 32/64 bit version v0.10.26
to enable/disable wait for input when process exists normaly/abnormaly

and press Ctrl + F5 run-no-debug does work ...

Em,where to find a previous release
Apr 22, 2014 at 6:03 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Apr 22, 2014 at 6:05 PM
I've made an issue for this. It sounds like it must be a race condition because it's occurring across a number of platforms and Node versions. We'll have to try and play with the timing on this and track it down. There were some changes to the debugger which made it more asynchronous which probably introduced this issue.

Thanks everyone for reporting it and we'll respond back here if we need any more info.