Express template will not run out of the box

Mar 30, 2014 at 4:23 PM
I get the following error when I create a new Express node.js project without making any modifications.

Express
500 Error: c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\views\layout.jade:1<br/> > 1| doctype 5 <br/> 2| html <br/> 3| head <br/> 4| title= title <br/><br/>doctype 5 is deprecated, you must now use doctype html
1| doctype 5
2| html
3| head
4| title= title
doctype 5 is deprecated, you must now use doctype html
at Object.Lexer.doctype (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\lexer.js:253:13)
at Object.Lexer.next (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\lexer.js:846:15)
at Object.Lexer.lookahead (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\lexer.js:114:46)
at Parser.lookahead (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\parser.js:100:23)
at Parser.peek (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\parser.js:77:17)
at Parser.parse (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\parser.js:115:26)
at Parser.parse (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\parser.js:129:24)
at parse (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\jade.js:95:62)
at Object.exports.compile (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\jade.js:154:9)
at Object.exports.render (c:\users\bmmathe.aaron\documents\visual studio 2013\Projects\ExpressApp1\ExpressApp1\node_modules\jade\lib\jade.js:258:15)
Coordinator
Apr 1, 2014 at 12:24 AM
Hi! This is fixed in the dev build available for download, and will be in the Beta release coming up. I think the change mentioned in the error is the only thing you need to change (change 5 to html). Thanks for letting us know anyway :)