This project is read-only.

Cannot debug?

Dec 16, 2013 at 10:28 AM

Has anyone come across this issue & can possibly help me?

I just can't seem to get debugging working (F5). Running without debugging (Ctrl + F5) works fine. When I do a debug, it just shows build was successful and then nothing happens after that - no Node command window pops up and no browser started.

Here are the steps that I did:
  1. Create a new Express app using the template
  2. Set a breakpoint in app.js
  3. F5 --> just shows build success in output window and then nothing after that.
  4. If I do Ctrl + F5 --> Node process runs in new command window popup & browser opens with app running fine
I also tried loading up an existing Node app and still the same issue.

My setup is VS2013 + Node x64 v0.10.23 running on Windows 8.1 x64.

I've even tried uninstalling & reinstalling a few times but still same issue. I've even disabled some VS plugins (ReSharper, VsVim etc) to see if they could be the cause of the issue but still no luck. Not exactly sure what could be causing it?
Dec 16, 2013 at 6:19 PM
Hi lyphtec,

Can you make sure that port 5858 is not currently in use? That's the debugger port that is currently hard-coded to use by NTVS (work item You can use the netstat command to see the ports that are currently in use.

On my machine, if I try to debug 2 NTVS apps at the same time (2 instances of VS), then the second instance behaves exactly the way you described, because the port is in use by the first instance of VS.
Dec 17, 2013 at 12:19 AM

Yeah - I'm pretty sure port 5858 is not currently in use when I try to debug from VS - and I only have 1 instance of VS running.