This project is read-only.

Copying node_packages to obj/Debug + looong path

Jul 17, 2014 at 12:08 PM
Error   16  Unable to copy file "c:\source\xxx-project-name\node_modules\grunt-contrib-cssmin\node_modules\maxmin\node_modules\gzip-size\node_modules\browserify-zlib\node_modules\pako\benchmark\implementations\inflate-pako-untyped\index.js" to "obj\Debug\.\node_modules\grunt-contrib-cssmin\node_modules\maxmin\node_modules\gzip-size\node_modules\browserify-zlib\node_modules\pako\benchmark\implementations\inflate-pako-untyped\index.js". The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.    C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v12.0\Node.js 
I understand the msbuild 248 limitation cannot be fixed. Why do the node_packages folder get copied though? Is there a way to disable?
Jul 17, 2014 at 6:39 PM
NTVS leverages the powers of VS for debugging, publishing, project system, etc... At times this means we get some undesirable and unnecessary behaviors. We believe this may be one of them. I've opened an issue to see if we can shutdown this unnecessary copy
Jul 17, 2014 at 6:41 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Marked as answer by RickWinter on 7/25/2014 at 9:17 AM