This project is read-only.

Solution failing to load with 14-May release

May 15, 2014 at 11:15 AM

I have a solution with a mix of TypeScript and NTVS projects. There are 12 of the latter.

After the installation, I am no longer able to open the solution. It says "loading..." with the blue line stuck about a 1/4 complete.

This is VS 2013 with the Spring Update (RTM).

I tried repair and uninstall/install, but that did not help. I tried opening a smaller solution (just one NTVS project) and that opened successfully - although it does take a long time to open.

I've had to rollback. Unfortunately I'm not able to share the solution.

Let me know if I can provide further information.
May 16, 2014 at 1:28 AM
How was the CPU usage for devenv when it was stuck loading that solution? If it's about 0%, it's probably yet another deadlock bug (we've fixed a few for the dev release). For the ones I experienced personally, I was usually able to load the solution if I killed VS and tried again. Your solution is larger than mine though, so I don't know if that increases the odds of failing.
May 17, 2014 at 10:38 PM
Please try deleting your .suo file before loading the solution. That just worked for me.
May 18, 2014 at 11:51 AM
@huguesv, thanks for the suggestions.

Here's some more information.

The CPU usage when devenv is stuck is 0%. So yes, the problem is probably the deadlock bug.
Killing VS and trying again does not help in my case: it's stuck every time.

The last suggestion of deleting the .suo file worked and I was finally able to load the solution.

However, after a reboot, it hung again. And it appears I have to go through a cycle of Kill VS => Delete .suo => Start VS, every time this happens.

On another note, the installer also appears to get stuck on "Updating extension registration with Visual Studio..." for over two minutes at times.
May 19, 2014 at 6:21 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
May 19, 2014 at 6:27 PM
2 mins sounds about right for that part of the installation (unfortunately). It's proportional to the number of extensions you have in Visual Studio. Ultimate, which has the most extensions, will usually take more time, Express for Web will take less.

I created an issue for the load hang, we'll try to release another dev build once we have a fix for it. For now, I would just delete the .suo file every time before opening the solution.