JS-style comment autocompletion missing?

Apr 2, 2014 at 7:56 AM
Edited Apr 2, 2014 at 7:58 AM
I've been trying out NTVS, and I can't figure out how to get JS-style comments to autocomplet in .js files that are part of an NTVS project. I have Resharper and VS Web Essentials installed as well.

When I'm editing a JavaScript file, I want to type this:
/**
And the editor should autocomplete (where the pipe is the cursor):
/** | */
Now, I should be able to press enter as many times as I want when I edit this comment, and it should add *s at the beginning of the line, indented as appropriate.

When I'm editing .ts files and .js files that are not part of an NTVS project (e.g. as part of a website), then this desired behavior occurs. However, I can't figure out how to get it to work for .js files in an NTVS project. It seems like a pretty minor thing to be missing but it's actually pretty irritating to have to manually indent and align all of the *s properly to fit the style guidelines.

Is there an option that I'm missing somewhere or is this not supported right now? Thanks for your help.
Coordinator
Apr 7, 2014 at 9:16 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Coordinator
Apr 7, 2014 at 9:16 PM
thanks - we'll take a look.